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LAB 6 - Working with Surfaces

This lab covers how to use additional cross section and profile tools to review surface data.

Chapter Objectives:

 Learn how to use cross section tools to cut sections on a skew to the alignment.

 Learn how to cut sections at specific locations based on graphic elements.

 Learn how to use level filters to find specific levels or groups of levels to turn on or off.

 Learn how to update components, features or surfaces on cross sections.

 Learn how to annotate points or features on cross sections.

 Learn how to use feature filters to find specific features for displaying or annotating.

 Learn how to cut profiles along graphic elements.

The following files are used in this lab:

 C:\Projects\12345\Bridge\Working \CU12345BRDG_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for interchange

 C:\Projects\12345\Design\InRoads\12345 SH52

 C:\Projects\12345\Design\InRoads\12345 SH119 SH52 Interchange.alg

 C:\Projects\12345\Bridge\Drawings\Reference_Files\12345BRDG_Model_D-16-DU.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Templates\ 
CDOT_Template-Library.itl

Lab 6.1 - Open Project Data

1. Open MicroStation and InRoads using the C:\Projects\12345\Bridge\Working 
\CU12345BRDG_Model.dgn file.

2. Verify the correct XIN file is loaded.

3. Select File > Open from the InRoads menu.

4. Open C:\Projects\12345\Design\InRoads\12345 SH52 and 12345 SH119 SH52 
interchange.alg. 

5. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for 
interchange.

Lab 6.2 - Create Skewed Cross Sections from Graphics

In the previous lab, a cross section set was created based on SH52 at an even interval along the 
alignment and all sections were perpendicular. In this section, cross sections are created on a 
skew to the alignment for review purposes.

1. Delete any MicroStation graphics currently in the design file.
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2. Select Geometry > View Geometry > All Horizontals.

3. Fit the MicroStation view.

4. Zoom in to the approximate area shown.
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5. In MicroStation, select the Element Selection tool.

6. While holding down the <Ctrl> key on your keyboard, <D> on the four elements shown 
here. 

Note: This makes a MicroStation selection set from the wall alignment graphics.

7. Select Tools > Options > Factors.

8. <D> the lock icon.
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9. Set the Text Scale Factor to 40.

10. <D> Apply, then Close.

11. Make SH52-H the active alignment.
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12. Select Evaluation > Cross Sections > Create Cross Sections.

13. Toggle on the two surfaces.

14. Select the Custom > General branch.

15. Set the Type to Linestring.

16. <D> Graphics.

Note: The list of stations where the graphics cross the alignment is shown in the dialog. If 
an entry is highlighted, the information on the right shows the offsets and the skew 
angle also.

17. <D> Apply.
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18. <D> a clear area in the design file for the bottom left corner of the cross section set.

19. Review sections by zooming in or by using the Cross Section Viewer.

Note: The cross sections are created based on the graphic elements. In this case, they are 
graphical displays of alignments, but they can be graphics drawn in MicroStation 
as well. Next, elements representing bearing lines and the pier centerline are used 
to create sections.

20. Back in the Cross Section dialog, highlight the list of custom stations and choose Delete 
on the keyboard.

21. <D> Close.

22. Clear the selection set of graphics by selecting the Element Select tool and <D> in a 
clear area of your file.

Note: The graphics representing the centerline and bearing lines are currently in a 
reference file and on a level that is turned off. 

23. Select File > Reference from the MicroStation menu.
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24. Turn on the display of the BRDG_Model_D_16-DU.dgn reference.

25. Close the Reference dialog box.

Note: Bearing and Pier centerlines are shown in the file. This reference was attached in 
the previous lab.

Note: It will be easier to see the new elements if the alignment levels are turned off. To 
facilitate finding the appropriate levels, level filters are used. Level filters allow the 
segregation of levels based on predefined criteria, such as all alignment levels, all 
bridge levels, etc. When a level filter is active, the dialogs listing levels only show 
those that pass the filter, making it easier to find specific ones.

26. In MicroStation, select Settings > Level > Display.

27. Toggle View Index 1 on and all others off.

28. Set the Active Level to Default.

29. Toggle Show Level Name or Filters to Levels.
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30. Set the List Filter to Alignment

31. Scroll through the list and notice only alignment levels are displayed.

32. Right-click in the level list and choose All Off.
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Note: In the MicroStation view, notice the alignments levels are now off and the bridge 
levels are still on. 

33. Right-click in the level list and choose All On.
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Note: Level filter are used in two ways. One, as described above, they are used to 
segregate the level lists to make it easier to find the necessary levels. They can also 
be used to turn on or off all associated levels.

34. Toggle the Filter to (none).

35. Toggle Show Level Name or Filters to Filters

36. Highlight Bridge-All.

37. Fit the MicroStation view and notice that the alignment levels are now off and only bridge 
levels are on.

38. Clear any previous selection set.
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39. Make a selection set from the Pier and Bearing MicroStation graphics.

40. Select Evaluation > Cross Section > Create Cross Section.

41. In the Cross Section dialog on the Custom > General branch, set the Type to Linestring.

42. <D> Graphics.

43. In the Level Display box, toggle off the Bridge-All filter to turn all levels back on.

44. In the Create Cross Section command, <D> Apply and then <D> in a clear area of the 
file.

45. <D> Close.

Note: Three cross sections are created for the three lines in the selection set.

46. Do not close out of the Create Cross Section command.
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47. Close the Level Display box.

48. Review your new custom cross section set.

49. In the Create Cross Section dialog box, select Save As.
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50. Key in 12345BRDG_Model _D-16-DU for the file name.

51. Select Save.

Note: In the future, these sections can be re-created by loading this text (*.xsc) file rather 
than selecting the graphic elements.

52. Zoom in to the second cross section.

Lab 6.3 - Update and Annotate Cross Sections

You can update a cross section set to turn on or off the display of components, crossing 
features, projected features or surfaces. You can also refresh the display of these items if 
changes have been after creating the cross sections.

Cross section points and segments can be annotated as well. If you want to annotate specific 
points, you can choose the corresponding features for annotation. However, the features must 
first be displayed on the cross section before they can be annotated.

In this section, you will use both the Update Cross Section and Annotate Cross Section 
commands. First, to more easily see the design surface, you will toggle off the components.

1. Select Evaluation > Cross Section > Update Cross Section.

2. Verify the Section Set is the current one.

3. Set the Mode to Display Off.

4. Highlight Components at left.
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5. Highlight the SH52 Surface.

6. Right-click in the component list and <D> Select All.

7. <D> Apply, then Close.

8. Review the cross section to see that components have been turned off.

Note: To assist in evaluating the cross sections, it is often helpful to see the elevations, 
which can be annotated using Annotate Cross Sections.

9. Select Evaluation > Cross Section > Annotate Cross Section.

10. Load the preference Proposed Grades Only.
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11. Select the Set of skewed sections.

12. Toggle on the SH52 surface.

13. <D> Apply, then Close.

Note: The elevations are annotated for every point on the proposed grade.

Note: Often, a more useful option is to annotate the elevations of only certain points. This 
is accomplished by first displaying the features in the proposed model on the cross 
sections.

14. Select Evaluation > Cross Sections > Update Cross Sections.

15. Select the set of skewed sections.

16. Set the Mode to Display On.

17. Select Crossing Features.
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18. Highlight the SH52 Surface.

Note: Look in the feature list and notice that there are several features. The surface 
contains features for each of the lifts seen on the cross sections earlier. The features 
on the finished grade, which are triangulated, are the ones typically annotated in 
this case. Rather than scrolling through this list and highlighting just those, a 
feature filter is used.

19. Select Tools > Locks > Toolbar to toggle on the locks toolbar if it is not on already.

20. On the Update Cross Section box, select Filter...

21. In the feature filter list, select XS_Excluded from Triangulation and select OK.
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22. Toggle on the Feature Filter lock.

Note: The feature filter has no effect unless the lock is on.

23. In the Update Cross Section box, scroll through the list of features and note the number is 
greatly reduced.

Note: The filter chosen, XS_ Excluded from Triangulation eliminates non-triangulating 
features from any dialog box that lists features. While it is very handy, it can also 
be confusing when features that exist do not show up in the list. For that reason, the 
lock is toggled off after use. There are several pre-defined filters that can be used 
to segregate features. These filters are stored in the XIN file.
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24. Highlight the Centerline Top and the left and right Laneline-Top1 features.

25. <D> Apply.

Note: Small ‘+’ signs are shown on the cross sections. These mark the location of the 
features and can now be annotated.

26. <D> Close.

27. Toggle off Feature Filter lock.

Note: It is best to leave this lock off unless you need it.

28. Select Evaluation > Cross Section > Annotate Cross Section.
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29. Load the preference Proposed Grades Only.

30. Select the set of skewed sections.

31. Toggle on the SH52 surface.

32. Select Points and toggle off Include Points.
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33. Select Features and toggle on Include Features.

34. Select Annotate under Features.

35. Highlight the three features listed.
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36. <D> Apply, then Close.

Note: Offsets and elevations are annotated for only the three features on the proposed 
grade. The previous annotation was deleted since you displayed these graphics in 
Pencil mode.

Lab 6.4 - Creating Profiles from Graphics

In addition to cutting skewed sections based on graphic elements, profiles can also be generated 
from graphics. The main differences between the two options include:

 The bottom axis of Cross Sections list offsets from the reference line along which they are 
created (alignment, graphic, or multi-point).

 The bottom axis of a Profile lists stationing, even if the profile is cut from a graphic. For 
profiles cut from graphics or multi-points, the stationing begins at 0+00.

In this section, you will generate a profile showing existing and proposed surfaces along a the 
pier centerline graphic. Since the graphic is in a reference, you will first draw a new line the 
active file to use for profiling.

1. In MicroStation select the Place Line command.

2. Place a new line by snapping to the two end points of the pier centerline.

3. Select Evaluation > Profile > Create Profile.

4. Select General.
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5. Toggle on both surfaces.

6. Select Source.

7. Toggle on Graphics Alignment.

8. If you key in a name in the Graphics Alignment field, an alignment is created for the 
graphic element selected after choosing Apply. 
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9. <D> on the Include Branch.

Note: If you want to display crossing features on your cross section like pipes or utilities, 
toggle on Crossing Features. These features must first exist in the surface(s) 
you’re showing on the sections. The feature’s style controls if the feature can be 
shown on the cross section.

Note: If you want to show features that fall outside the cross section, toggle on Projected 
Features. This will show the orthogonal projection of the features onto the cross 
section. You also have the option of specifying a Bandwidth to either side of the 
section to project the features.

10. For this exercise, leave Crossing Features and Projected Features turned off.

11. <D> Apply.

12. <D> on the line you drew over the pier centerline element.

13. <D> to accept the element.

14. <D> a clear area in the file.
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Note: The profile is created showing both surfaces. Since there is not an alignment 
associated with this review profile, some of the post-processing commands for 
profiles, such as annotating and updating are not available. Profiles that need to be 
annotated and/or updates should be cut using an alignment, or an alignment should 
be created when the profile is cut by specifying an alignment name as noted above.

Chapter Summary:

 Custom cross sections are used to create sections that are not based on an interval or 
perpendicular to an alignment.

 The setup for custom cross section sets may be saved to a text file and loaded later to cut 
sections at the same location.

 Level filters can create a subset or group of levels to easily turn an entire group of levels on 
or off. They can also help you find individual levels more easily.

 Feature filters create a subset or group of surface features for displaying in plan, profile or 
cross section. They can also help you find individual features more easily.

 Profiles can be cut based on alignments or graphics.
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