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First time users of Microstation should read “Chapter 2 - Getting Started in 

MicroStation“ available online at: 

http://www.coloradodot.info/business/designsupport/cadd/manuals-training-

resources/v8i-ss2-training-materials/microstation/microstation-v8i-ss2-

guide/chapter2/view  

 

B.1 CONFIGURATION 

Training materials, manuals, workflows, video tutorials and other resources 

can be accessed online at:  

http://www.coloradodot.info/business/designsupport/cadd. 

The training videos cover assorted subjects.  There are also a number of CDOT 

workflows in pdf format for the MicroStation user that address specific 

drafting issues such as Print Organizer, Linking Word / Excel Documents to 

MicroStation, Useful MicroStation Key-ins, Raster Manager, etc. and several 

InRoads related workflows. 

The Bridge Detailer should become familiar with all the available information 

posted online at the above mentioned web locations.  In addition, this 

information is available through MicroStation Help and CDOT Help links 

available on the MicroStation menu bar. 

 

Fig. B.1-1 Help and CDOT Help  
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B.2 SEED FILES 

When working in MicroStation, the Bridge Detailer has the option of opening 

an existing drawing or starting a new one based on the existing bridge 

templates.  Drawing templates used in MicroStation are called “seed files” 

and are included in the configuration files.   

Two seed files are available for the preparation of bridge drawings. They are 

named Bridge-3D-Seed_CDOT.dgn and Bridge-2D-Seed_CDOT.dgn.   

These seed files are located on C:\Workspace\Workspace-CDOT_V8i\Standards-

Global\MicroStation\Seed. 

The bridge 2D seed file contains two models named Linework and Border.   

In the Linework model the detailer will create all line work for details at 

full scale (1:1).  Linework model is the default model that cannot be 

deleted.   

By default, the Border model contains the cell SHEET_Design-Sheet 

representing the CDOT border (ANSI-B size 11”x17”).  The insertion point for 

the cell is at coordinates (0,0).  This is a non-ProjectWise border. 

In order to avoid display depth, global origin and other 3D issues, it is 

recommended that the 2D seed file be used for all drawings that do not 

require 3D presentation. 

It is also recommended that a 2D model be used for the Border.  

The Border model will contain the information from the Linework model 

referenced at the appropriate scale to be displayed in a readable manner on 

the plan sheet. 

There are 3-model types available in MicroStation: design models, drawing 

models, and sheet models (see MicroStation Help for definition).  By default, 

in the bridge seed files both Linework model and Border model are design 

models.  The border model is set up so the detailer can switch to sheet type 

if so preferred.  One of the benefits of sheet models is they can be selected 

specifically by the Print Organizer utility.   

You can open the Model Properties dialog box by selecting File > Models and 

then click on the Edit Model properties icon. (see Fig. B.2-1) 
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Fig. B.2-1 Models and Model Properties Dialog 
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B.3 BORDERS 

There are two types of plan sheet border: ProjectWise and non ProjectWise.  

For ProjectWise border functionality, refer to the documentation available 

online at http://www.coloradodot.info/business/designsupport/cadd.  Both 

border types are available in the CDOT Menu. 

The CDOT border is typically plotted on 11” x 17” paper at scale 1”=1’ and it 

is a cell named SHEET_Design-Sheet located in General.cel library file.  It 

can be inserted into the Border model from the CDOT Menu, under Drafting.   

 

Fig. B.3-1 Border Selection from Drafting Group  

  



January 31, 2013 Appendix B Page 5 of 20 

 

The ProjectWise border is available from the CDOT Menu, as shown below. 

 

Fig. B.3-2 - ProjectWise Border 
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The middle part of the border requires the insertion of a cell for the 

Resident Engineer/Bridge Unit information.  This can be inserted from CDOT 

Menu > Drafting > Border RE or CDOT Menu > Bridge > Border. 

 

Fig. B.3-3 Border Selection from Bridge Group  
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B.4 REFERENCE FILES 

A Reference is a model that is attached to and displayed with the active 

model for printing or construction purposes.  You can reference/attach a 

model from a different dgn file or a model from the same dgn file (like 

attaching Linework model into the Border Model of the same dgn file).  For 

that, go to File > References and then select Tools > Attach… and browse for 

the dgn file that you want to reference. 

In order for the objects in a reference to be printed with the appropriate 

line weights, make sure to check the Line Weights box in the Reference 

Presentation dialog box (References > Settings > Presentation).  Check the 

Use View Flags box, click on Line Weights, then de-select the View Flags 

check box and select OK. 

 

 

Fig. B.4-1 Reference Presentation Dialog Box 
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B.5 LEVELS 

Levels in MicroStation are defined in the CDOT configuration by Color, Style, 

and Weight. 

Currently, there are 13 general bridge levels (see table below) and over 150 

specific bridge levels defined in the CDOT configuration.  

The specific bridge levels mimic the general bridge levels, that is, all 

Outline levels print the same as the general Outline level, having the same 

line style and lineweight, but a different color.  The purpose for the 

additional levels is to help in turning the levels off/on in different views 

and provide additional information for the detailer when developing linework. 

The following table indicates the MicroStation general levels to be used to 

comply with the requirements described in Chapter 2 of the Bridge Detail 

Manual: 

Level Name Color Linetype Lineweight How it looks in MicroStation 

BRDG_BREAK 7 0 0  

 

 

 

 

 

 

 

 

 

 

 

 

BRDG_CENTER 7 4 0 

BRDG_CONSTRUCT 4 0 1 

BRDG_CONTROL 3 0 3 

BRDG_DASHED 2 3 1 

BRDG_DIMENSION 2 0 1 

BRDG_FROZEN 2 0 0 

BRDG_HIDDEN 5 5 1 

BRDG_OUTLINE 3 0 2 

BRDG_PATTERN 6 0 1 

BRDG_REBAR 1 BRDG_Rebar 3 

BRDG_TEXT 4 0 1 

BRDG_TITLE 1 0 3 

The addition or modification of bridge levels requires concurrence within the 

BUG (Bridge Users Group) committee at CDOT.  The detailer is advised to use 

the levels defined in the configuration. 

There are various ways to view and select an active level, as follows:   

1. Select the level from the Attributes tool box, as shown in Fig. B.5-1.  
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Fig. B.5-1 Active Level Selection  

2. Use the CDOT menu by selecting the “Bridge” CDOT group> Bridge Levels> 

and using the pulldown “Type” menu to narrow the search. (Fig. B.5-2)  

 

Fig. B.5-2- Bridge Level Selection from CDOT Menu 
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3. Double click on a level in the level display window. (Fig. B.5-3) 

 

Fig. B.5-3 - Bridge Level Selection from the Level Display 

Level filters are a useful way to group associated levels for the purposes of 

viewing or removing unneeded levels from view.  Filters can be used in both 

the Attributes tool box and the Level Display window.  There are several 

predefined filters available that cannot be modified by the user. (see Fig. 

B.5-4)   

“On the fly” filters can be created in the Level Display window.  To do that, 

first click on the Level Display icon on the Primary Tools tool box, then 

click the List Filter icon and select Untitled, then enter the desired filter 

criteria in the appropriate categories (Name, Color, Line Style etc) in the 

top row.  The example in Fig. B.5-5 shows a filter created “on the fly” with 

“brdg” in the name, a line style value of “0” and a line weight value of “3”.  

This filter can be toggled on/off by clicking the List Filter icon and 

selecting None.  The filter remains until you exit MicroStation.   
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Fig. B.5-4 – Some of the CDOT Predefined filters 

 

 

Fig. B.5-5 – Example of filters “on the fly” 
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All the configuration levels have an assigned color associated with the 

level.  Although the color number of the level can’t be changed, its 

appearance to individual user can.  The user can personalize the color table 

without affecting the plot styles:  Settings > Color Table…> Select the color 

you want to change, click on Change, pick the color you want to replace with 

and click OK, then select Attach. 

 

 

Fig. B.5-6 - Personalizing the Color Table 
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B.6 CELL LIBRARIES 

Cell libraries are ordinary MicroStation design files that have a .cel 

extension, with multiple models, one for each cell. 

Staff Bridge has created cell libraries containing useful details for use in 

detailing CDOT bridge projects. Those library files are named Bridge.cel, 

Bridge_Repair.cel and BridgePiping.cel. There are also local developmental 

cell libraries for testing new cells prior to incorporating them into the 

configuration. 

To view all cells contained in a library, open the Cell Library dialog box by 

selecting Element > Cells and then File > Attach File.  As an alternative, 

the CDOT Menu can be used by selecting >Bridge > Cells and then selecting the 

appropriate cell type. 

MicroStation provides other methods of accessing the cell libraries, 

including customized toolboxes, cell selector tools, etc. 

The detailer may choose to create his or her own cells and cell libraries. It 

is important to place the cell origin in a useful location and to place each 

element of the cell in the appropriate level.  The cell can then be saved in 

one of the existing developmental libraries (located on \\public\Bridge 

Common\MicroStation\CELLS) so everyone has access to it. 

For more information on how to create a cell library and cells, see the 

MicroStation Help.  
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B.7 ANNOTATION / TEXT STYLES 

The following table describes the text styles used on bridge drawings: 

Text Style Use 

07_ENG-100 General notes and detailing text 

07_ENG-80 Reduced width font for use in conserving space on plan sheet 

10_ENG-100 Title Text 

05_ENG-100 Rebar dimensioning normal 

05_ENG-80 Rebar dimensioning – conserving space 

 

Unfortunately, outdated text styles that should no longer be used can still 

be found in archived drawings and they should be replaced with the new styles 

from the table. For that, the methodology is: Element > Text Styles > Select 

style to change and right click > Remap Elements…> Pick the new style in the 

Destination box, then click OK.  Once replaced, the old text styles can and 

should be purged (deleted).  A note of caution: remapping might cause 

unwanted changes in the text appearance that need to be addressed. 

 

Fig. B.7-1 - Replacing old text styles 

Text notes are controlled by the dimension styles and they should be put in 

the level Text.   
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B.8 DIMENSION STYLES 

The MicroStation Dimension Style for most details should be CDOT 3.  This 

style is a normal architectural style (feet and inches). 

Dimension style CDOT 5 should be used for the footing & piling layout plan.  

It shows dimensions in decimal feet, which is more appropriate for the 

surveying required to locate the piles and footings.  

The dimension style dialog box can be accessed from Element – Dimension 

Styles. 

 

Fig. B.8-1 Dimension Style Dialog Box - Units 

The orientation of the dimension text can be modified from Dimension Styles 

settings – Text – Orientation – Horizontal/Aligned.   
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Changes can be made to the dimension style as the need arises during 

detailing, i.e., when using angular dimensioning, angle format can be changed 

from units “Angle” to units “Length” to show arc size length in feet and 

inches instead of the angle value in degrees/ minutes/ seconds. 

 

Fig. B.8-2 Dimension Style Dialog Box – Changing Angle Format 

Text notes are drawn by default with just an arrow.  You can change the 

terminator by selecting a cell or symbol (Element > Dimension Styles > 

Geometry > Terminators > Symbols > Note: select Cell or Symbol).  The symbols 

are not set up currently.  The default cell is set up to be the integral 

arrow cell that looks like this (see Fig. B.8-3). 
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Fig. B.8-3 Dimension Style Dialog Box - Geometry  
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B.9 PRINTING 

Before printing the drawing it is important to apply the print style, whether 

it is a hard print or a pdf print. In order to do that, from the Print menu > 

Settings > Apply Print Style select the printer/plotter desired.  By default, 

the CDOT Default Printer is the one that is used for the hard print. 

CDOT PDF (Draft Quality) is of sufficient quality for creating the majority 

of drawings.  CDOT PDF (High Quality) may be required for some rendering. 

 

 

Fig. B.9-1 Print Style Selection 
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Currently, there are several CDOT printer drivers available.  The printer 

drivers control plotting devices, plot sizes, pen tables etc. The standard 

plot size for all bridge drawings is 11x17.  The default pen table (CDOT-

PenTable.tbl) prints all bridge levels in black/white.  If a color print is 

desired, the detailer will go to Print > PenTable > Attach and select one of 

the color pen tables available. (see Fig. B.9-2) 

 

Fig. B.9-2 Pen Table Selection 
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B.10 MINIMUM ELECTRONIC STANDARDS FOR MICROSTATION DRAWINGS 

1) Final view for plotting hardcopy shall be View 1, a Top View. This 

view shall be located in the “Border” model. 

2) Unless creating 3D elements at elevation, all linework should be at 

elevation zero. 

3) Default symbology should be used for configuration levels. 

4) Linework should be drawn at full scale. 

5) Sheet models should generally use 1” = 1’. 

 

 

B.11 MICROSTATION THINGS THAT ARE GOOD TO KNOW 

1) A practice that seems to work well for copying from one file to another: 
Reference in the item to be copied, select and copy the element of 

interest.  You can detach the reference when you’re finished with it. 

2) The drawing border should be placed at 0,0,0.  A trick for finding this 
location is to take the following steps: 

o select the “Place SmartLine” tool,  

o data on the beginning point,  

o type p, 

o type “0,0,0” (zero, zero, zero, including commas), click enter,  

o data end point. 

You will have created an arrow (of sorts) that points to the 0,0,0 

coordinate.  Consistently placing line work at this location will help 

preclude the loss of drawings in the vast expanses of MicroStation. 

3) When adding dimensions it is helpful to open the Dimension Styles window 
(Element\Dimension Styles) so that you can make changes on the fly in 

placement and symbols. 

4) Draw line work in “default” model and change the model name to 

“linework”.  The default model is the Master model, that can’t be deleted 

by mistake.  If the Bridge seed file is used, the linework model is 

already set up as the default. 

5) If menus/windows disappear off your screen or are halfway off, making 
them unusable, change your screen resolution to a different setting, 

reposition the menu/window and then go back to default screen resolution. 

To get to the screen resolution, right-click the mouse in your desktop 

screen. 

6) When the Sheet Border is created using 1” = 1’, and the Annotation Scale 

is locked ON and is 1”=1’, life is good and text is always the right size 

for the drawing. 


